aboutsummaryrefslogtreecommitdiff
path: root/discocaml/default.nix
diff options
context:
space:
mode:
authorNathan Ringo <nathan@remexre.com>2024-01-18 10:58:36 -0600
committerNathan Ringo <nathan@remexre.com>2024-01-18 10:58:36 -0600
commit00d0bfced902e97eeae5257c14134d4bc7efc710 (patch)
treeee026f328614e03aec3ed373d9f2e6c8e255f834 /discocaml/default.nix
parent7017762a4a38266aa88976be141f7bd663647edc (diff)
Commands to interact with discocaml, associated IPC.
Diffstat (limited to 'discocaml/default.nix')
-rw-r--r--discocaml/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/discocaml/default.nix b/discocaml/default.nix
index 0045cdf..392c146 100644
--- a/discocaml/default.nix
+++ b/discocaml/default.nix
@@ -1,10 +1,10 @@
-{ buildDunePackage, ocaml-compiler-libs, ppx_deriving, ppx_import, ppxlib }:
+{ buildDunePackage, yojson, ocaml-compiler-libs, ppx_deriving
+, ppx_deriving_yojson, ppx_import, ppxlib }:
buildDunePackage {
pname = "discocaml";
version = "0.1.0";
minimalOcamlVersion = "5.1";
src = ./.;
- nativeBuildInputs = [ ];
- buildInputs = [ ppx_deriving ppx_import ppxlib ];
+ buildInputs = [ ppx_deriving ppx_deriving_yojson ppx_import ppxlib yojson ];
}