aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorNathan Ringo <nathan@remexre.com>2024-05-05 17:20:00 -0500
committerNathan Ringo <nathan@remexre.com>2024-05-05 17:20:00 -0500
commit0874c7f1852145c3ae62f1e28dc10c0c89d78b45 (patch)
tree0717d0293a78510ac62ea7f463da4ef6d54229cb /flake.nix
parent2ec6d7d09e2cd6c08686aae9427b46a217972675 (diff)
Not yet working UART...
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix18
1 files changed, 16 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index e49859b..0dd1743 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,7 +1,16 @@
{
+ inputs.nixpkgs.url = "github:NixOS/nixpkgs";
outputs = { self, flake-utils, nixpkgs }:
flake-utils.lib.eachDefaultSystem (system:
- let pkgs = nixpkgs.legacyPackages.${system};
+ let
+ pkgs = nixpkgs.legacyPackages.${system};
+ bsc-contrib = pkgs.fetchFromGitHub {
+ name = "bsc-contrib-src";
+ owner = "B-Lang-org";
+ repo = "bsc-contrib";
+ rev = "fc26b91c8add9660204c4311dcc60d223ed23ea5";
+ hash = "sha256-7H+R7QwcyskrXGO51zZuuyIwZZROc25gJy9nqg/I6lM=";
+ };
in rec {
devShells.default = pkgs.mkShell {
inputsFrom = builtins.attrValues packages;
@@ -9,9 +18,14 @@
pkgs.bluespec
pkgs.gtkwave
pkgs.icestorm
- pkgs.verilator
+ pkgs.nextpnr
+ pkgs.picocom
pkgs.yosys
];
+ env = {
+ BSC = pkgs.bluespec;
+ BSC_CONTRIB = bsc-contrib;
+ };
};
packages = { };