aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorNathan Ringo <nathan@remexre.com>2024-10-02 15:28:46 -0500
committerNathan Ringo <nathan@remexre.com>2024-10-02 16:29:42 -0500
commita50049ae050c625e66b5f9280929cbf2f98cdec4 (patch)
tree14e747121161327a8b91ca587c20c70c2a061966 /flake.nix
parent0b243018d200e22dd088e79d61b06aaf64bbe4c2 (diff)
Adds tristates for HyperBus.
This might need to be remodularized; Bluesim doesn't support Inouts, so this fails to build there for now. It probably makes sense to split out the board to its own package, then go back to having Top and TopSim packages, where only Top wires it up to Tristates.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 7877aa2..062a6da 100644
--- a/flake.nix
+++ b/flake.nix
@@ -17,7 +17,10 @@
pkgs.gtkwave
pkgs.picocom
];
- env.BSC = pkgs.bluespec;
+ env = {
+ BSC = pkgs.bluespec;
+ BSC_SRC = pkgs.bluespec.src;
+ };
};
packages = {