summaryrefslogtreecommitdiff
path: root/boards/default.nix
diff options
context:
space:
mode:
authorNathan Ringo <nathan@remexre.com>2024-09-01 21:40:34 -0500
committerNathan Ringo <nathan@remexre.com>2024-09-01 21:40:34 -0500
commit158b7123b6a50b2e8d37529e01ccd94c9106c11a (patch)
tree9af446b259b8ac99524843e215513355668908ef /boards/default.nix
parent8cb34498eceef231927c444507b6787128c5f0d8 (diff)
Fix debuginfo and restore apps.
Diffstat (limited to 'boards/default.nix')
-rw-r--r--boards/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/boards/default.nix b/boards/default.nix
index 6c8c8a9..de0eb34 100644
--- a/boards/default.nix
+++ b/boards/default.nix
@@ -40,12 +40,15 @@ let
'';
installPhase = ''
runHook preInstall
- install -Dt $out kernel.elf
+ install -m0755 -Dt $out vernos_kernel.elf
+ install -m0644 -Dt $out vernos_kernel.sym
runHook postInstall
'';
+ dontFixup = true;
AS = "${arch.crossSystem}-as";
LD = "${arch.crossSystem}-ld";
+ STRIP = "${arch.crossSystem}-strip";
}
// args
);