summaryrefslogtreecommitdiff
path: root/crates/alloc_genmalloc/Cargo.toml
diff options
context:
space:
mode:
authorNathan Ringo <nathan@remexre.com>2024-09-12 18:14:13 -0500
committerNathan Ringo <nathan@remexre.com>2024-09-12 18:14:13 -0500
commitec991590e4e3b92e407060410ff33525dc740988 (patch)
tree287c2fa46f9814ce804c2dde60aa37e5823762cb /crates/alloc_genmalloc/Cargo.toml
parent128aa9bb0f0cd1410a30d45775e7627b01ed74a2 (diff)
Adds the start of a regular allocator, and some page table maintainence.
Diffstat (limited to 'crates/alloc_genmalloc/Cargo.toml')
-rw-r--r--crates/alloc_genmalloc/Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/crates/alloc_genmalloc/Cargo.toml b/crates/alloc_genmalloc/Cargo.toml
new file mode 100644
index 0000000..1099020
--- /dev/null
+++ b/crates/alloc_genmalloc/Cargo.toml
@@ -0,0 +1,9 @@
+[package]
+name = "vernos_alloc_genmalloc"
+version = "0.1.0"
+edition = "2021"
+publish = false
+
+[dependencies]
+allocator-api2 = { version = "0.2.18", default-features = false }
+contracts = { version = "0.6.3", default-features = false }