summaryrefslogtreecommitdiff
path: root/crates/kernel/Cargo.toml
diff options
context:
space:
mode:
authorNathan Ringo <nathan@remexre.com>2024-09-12 18:14:13 -0500
committerNathan Ringo <nathan@remexre.com>2024-09-12 18:14:13 -0500
commitec991590e4e3b92e407060410ff33525dc740988 (patch)
tree287c2fa46f9814ce804c2dde60aa37e5823762cb /crates/kernel/Cargo.toml
parent128aa9bb0f0cd1410a30d45775e7627b01ed74a2 (diff)
Adds the start of a regular allocator, and some page table maintainence.
Diffstat (limited to 'crates/kernel/Cargo.toml')
-rw-r--r--crates/kernel/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/crates/kernel/Cargo.toml b/crates/kernel/Cargo.toml
index 6fbabc1..cbdac2a 100644
--- a/crates/kernel/Cargo.toml
+++ b/crates/kernel/Cargo.toml
@@ -9,6 +9,7 @@ crate-type = ["staticlib"]
[dependencies]
cfg-if = { version = "1.0.0", default-features = false }
contracts = { version = "0.6.3", default-features = false }
+either = { version = "1.13.0", default-features = false }
log = { version = "0.4.20", default-features = false }
spin = { version = "0.9.8", default-features = false, features = ["fair_mutex", "use_ticket_mutex"] }
vernos_alloc_buddy = { path = "../alloc_buddy" }