summaryrefslogtreecommitdiff
path: root/kernel/Cargo.toml
diff options
context:
space:
mode:
authorNathan Ringo <nathan@remexre.com>2024-08-27 12:23:38 -0500
committerNathan Ringo <nathan@remexre.com>2024-08-27 12:23:38 -0500
commit15fd8115739da57c6aa64da9a2ac6e0f0b7ba088 (patch)
tree28a9032f3b0a3089f5fc1e8cf7587d6803085071 /kernel/Cargo.toml
parent251ea035fa2338db7b001af338d65875a9bc65ad (diff)
The start of the buddy allocator.
Diffstat (limited to 'kernel/Cargo.toml')
-rw-r--r--kernel/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/kernel/Cargo.toml b/kernel/Cargo.toml
index 5eb15af..87a2443 100644
--- a/kernel/Cargo.toml
+++ b/kernel/Cargo.toml
@@ -7,7 +7,9 @@ edition = "2021"
crate-type = ["staticlib"]
[dependencies]
+allocator-api2 = { version = "0.2.18", default-features = false }
bstr = { version = "1.10.0", default-features = false }
+cfg-if = { version = "1.0.0", default-features = false }
contracts = { version = "0.6.3", default-features = false }
either = { version = "1.13.0", default-features = false }
log = { version = "0.4.20", default-features = false }