summaryrefslogtreecommitdiff
path: root/crates/alloc_buddy/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/alloc_buddy/Cargo.toml')
-rw-r--r--crates/alloc_buddy/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/crates/alloc_buddy/Cargo.toml b/crates/alloc_buddy/Cargo.toml
new file mode 100644
index 0000000..5e5c882
--- /dev/null
+++ b/crates/alloc_buddy/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "vernos_alloc_buddy"
+version = "0.1.0"
+edition = "2021"
+publish = false
+
+[dependencies]
+allocator-api2 = { version = "0.2.18", default-features = false }
+contracts = { version = "0.6.3", default-features = false }
+static_assertions = { version = "1.1.0", default-features = false }
+vernos_alloc_physmem_free_list = { path = "../alloc_physmem_free_list" }
+
+[dev-dependencies]
+proptest = { version = "0.9.6", default-features = false, features = ["std"] }
+nix = { version = "0.29.0", default-features = false, features = ["mman"] }