summaryrefslogtreecommitdiff
path: root/crates/buddy_allocator/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/buddy_allocator/Cargo.toml')
-rw-r--r--crates/buddy_allocator/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/crates/buddy_allocator/Cargo.toml b/crates/buddy_allocator/Cargo.toml
new file mode 100644
index 0000000..e2a85d3
--- /dev/null
+++ b/crates/buddy_allocator/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "vernos_buddy_allocator"
+version = "0.1.0"
+edition = "2021"
+publish = false
+
+[dependencies]
+allocator-api2 = { version = "0.2.18", default-features = false }
+contracts = { version = "0.6.3", default-features = false }
+static_assertions = { version = "1.1.0", default-features = false }
+vernos_physmem_free_list = { path = "../physmem_free_list" }
+vernos_utils = { path = "../utils" }
+
+[dev-dependencies]
+proptest = { version = "0.9.6", default-features = false, features = ["std"] }
+nix = { version = "0.29.0", default-features = false, features = ["mman"] }