summaryrefslogtreecommitdiff
path: root/crates/kernel/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/kernel/Cargo.toml')
-rw-r--r--crates/kernel/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/crates/kernel/Cargo.toml b/crates/kernel/Cargo.toml
index 6c28dd8..5fef50b 100644
--- a/crates/kernel/Cargo.toml
+++ b/crates/kernel/Cargo.toml
@@ -7,7 +7,7 @@ edition = "2021"
crate-type = ["staticlib"]
[dependencies]
-allocator-api2 = { version = "0.2.18", default-features = false }
+allocator-api2 = { version = "0.2.18", default-features = false, features = ["alloc"] }
bitflags = { version = "2.6.0", default-features = false }
cfg-if = { version = "1.0.0", default-features = false }
contracts = { version = "0.6.3", default-features = false }
@@ -16,6 +16,7 @@ log = { version = "0.4.20", default-features = false }
spin = { version = "0.9.8", default-features = false, features = ["fair_mutex", "use_ticket_mutex"] }
vernos_alloc_buddy = { path = "../alloc_buddy" }
vernos_alloc_physmem_free_list = { path = "../alloc_physmem_free_list" }
+vernos_alloc_vma_tree = { path = "../alloc_vma_tree" }
vernos_device_tree = { path = "../device_tree" }
vernos_driver_riscv_timer = { path = "../driver_riscv_timer" }
vernos_utils = { path = "../utils" }