summaryrefslogtreecommitdiff
path: root/crates/kernel/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/kernel/Cargo.toml')
-rw-r--r--crates/kernel/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/crates/kernel/Cargo.toml b/crates/kernel/Cargo.toml
new file mode 100644
index 0000000..3d7b61b
--- /dev/null
+++ b/crates/kernel/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "vernos_kernel"
+version = "0.1.0"
+edition = "2021"
+
+[lib]
+crate-type = ["staticlib"]
+
+[dependencies]
+cfg-if = { version = "1.0.0", default-features = false }
+log = { version = "0.4.20", default-features = false }
+vernos_alloc_buddy = { path = "../alloc_buddy" }
+vernos_alloc_physmem_free_list = { path = "../alloc_physmem_free_list" }
+vernos_device_tree = { path = "../device_tree" }
+vernos_driver_riscv_timer = { path = "../driver_riscv_timer" }
+vernos_utils = { path = "../utils" }
+void = { version = "1.0.2", default-features = false }