summaryrefslogtreecommitdiff
path: root/crates/kernel/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/kernel/Cargo.toml')
-rw-r--r--crates/kernel/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/crates/kernel/Cargo.toml b/crates/kernel/Cargo.toml
index 3d7b61b..6fbabc1 100644
--- a/crates/kernel/Cargo.toml
+++ b/crates/kernel/Cargo.toml
@@ -8,7 +8,9 @@ crate-type = ["staticlib"]
[dependencies]
cfg-if = { version = "1.0.0", default-features = false }
+contracts = { version = "0.6.3", default-features = false }
log = { version = "0.4.20", default-features = false }
+spin = { version = "0.9.8", default-features = false, features = ["fair_mutex", "use_ticket_mutex"] }
vernos_alloc_buddy = { path = "../alloc_buddy" }
vernos_alloc_physmem_free_list = { path = "../alloc_physmem_free_list" }
vernos_device_tree = { path = "../device_tree" }