summaryrefslogtreecommitdiff
path: root/kernel/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'kernel/Cargo.toml')
-rw-r--r--kernel/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/kernel/Cargo.toml b/kernel/Cargo.toml
index cef382e..d6449e8 100644
--- a/kernel/Cargo.toml
+++ b/kernel/Cargo.toml
@@ -7,6 +7,12 @@ edition = "2021"
crate-type = ["staticlib"]
[dependencies]
+contracts = { version = "0.6.3", default-features = false }
+log = { version = "0.4.20", default-features = false }
+spin = { version = "0.9.8", default-features = false, features = ["mutex", "use_ticket_mutex"] }
[profile.release]
+codegen-units = 1
debug = true
+lto = true
+overflow-checks = true