aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorNathan Ringo <nathan@remexre.com>2024-05-05 22:30:50 -0500
committerNathan Ringo <nathan@remexre.com>2024-05-05 22:30:50 -0500
commitf9b73dc7b93bbf60f5b2281a5056c4339e049388 (patch)
tree5325a2e6ee78bb36179c5b2b4c56da806214e426 /flake.nix
parent0874c7f1852145c3ae62f1e28dc10c0c89d78b45 (diff)
triyng a uart from scratch... not yet working...
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 1 insertions, 13 deletions
diff --git a/flake.nix b/flake.nix
index 0dd1743..ef36aef 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,15 +2,7 @@
inputs.nixpkgs.url = "github:NixOS/nixpkgs";
outputs = { self, flake-utils, nixpkgs }:
flake-utils.lib.eachDefaultSystem (system:
- let
- pkgs = nixpkgs.legacyPackages.${system};
- bsc-contrib = pkgs.fetchFromGitHub {
- name = "bsc-contrib-src";
- owner = "B-Lang-org";
- repo = "bsc-contrib";
- rev = "fc26b91c8add9660204c4311dcc60d223ed23ea5";
- hash = "sha256-7H+R7QwcyskrXGO51zZuuyIwZZROc25gJy9nqg/I6lM=";
- };
+ let pkgs = nixpkgs.legacyPackages.${system};
in rec {
devShells.default = pkgs.mkShell {
inputsFrom = builtins.attrValues packages;
@@ -22,10 +14,6 @@
pkgs.picocom
pkgs.yosys
];
- env = {
- BSC = pkgs.bluespec;
- BSC_CONTRIB = bsc-contrib;
- };
};
packages = { };