summaryrefslogtreecommitdiff
path: root/crates/kernel/Cargo.toml
diff options
context:
space:
mode:
authorNathan Ringo <nathan@remexre.com>2024-09-14 17:37:48 -0500
committerNathan Ringo <nathan@remexre.com>2024-09-14 17:37:48 -0500
commit5a7617e4d524a74a4fb21f956fead71e789c454c (patch)
tree84832f1826f156d4ec54222c238fa247e4b09f34 /crates/kernel/Cargo.toml
parentec991590e4e3b92e407060410ff33525dc740988 (diff)
Start of a platform-independent paging interface.
Diffstat (limited to 'crates/kernel/Cargo.toml')
-rw-r--r--crates/kernel/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/crates/kernel/Cargo.toml b/crates/kernel/Cargo.toml
index cbdac2a..6c28dd8 100644
--- a/crates/kernel/Cargo.toml
+++ b/crates/kernel/Cargo.toml
@@ -7,6 +7,8 @@ edition = "2021"
crate-type = ["staticlib"]
[dependencies]
+allocator-api2 = { version = "0.2.18", default-features = false }
+bitflags = { version = "2.6.0", default-features = false }
cfg-if = { version = "1.0.0", default-features = false }
contracts = { version = "0.6.3", default-features = false }
either = { version = "1.13.0", default-features = false }